“The Fuse Was Blown!” in this Mesa 20/20 Stereo Amplifier

The music died when the AC line fuse blew in his Mesa 20/20 stereo amp.  What are we gonna do?  Call The Unbrokenstring Crew!

JC’s rig was built around the amp, so of course it was installed first at a place of honor in the bottom of the road case.

Exploratory surgery is fairly easy in this unit.  Everything is accessible once the top black panel is removed.

Here is a little Tech Porn.  A lot of versatility is designed into this amp.

Every tube in this unit is original.  These were all checked and packed safely to the side.

Here’s what a blown AG3 fuse looks like, just in case you hadn’t seen one before…

With the tubes removed and the power applied gradually through a Variac, the problem persisted.  Here, one of the red wires that sends high voltage to one of the output transformers is temporarily isolated from the circuit.

And this is the output transformer at the other end of that red wire.  As power was applied, it began to get hot.  Do you see the little round dents in the insulation?

Those little dents are from these rubber bumpers that help support the wire bobbin of the output transformer.  Current leaked from high voltage winding to the steel core laminations of the transformer.  The head generated by the electrical current melted the nylon bobbin, further damaging the transformer windings and leading to a cascading insulation breakdown in the unit.

Mesa Engineering had a few of these output transformers left in stock.  Here is a fresh one, via FedEx.

The new part is the output transformer on the right.

Now we are going to dress the wiring back through the chassis of the amplifier in a manner similar to the way the old part was installed.  Since the chassis is about one and a quarter inch thick, everything is super-easy to work on!

Except when the cabling goes underneath the circuit boards.   A pair of round-nosed pliers are used to snake the wires where they need to go.

And we come out the other side.  Recognize the red wires from the earlier picture?

These three wires are the four ohm / eight ohm output leads.  These were trimmed to length and tinned.

If you look closely, the colors of the wire insulation is painted on the circuit board, where each output lead belongs.  However, this color information did not match the original configuration of the amplifier.  I’m glad I took all those pictures before I started removing wires!

Here is another view, showing the final lead dress.  The amp is back together for final test.

This is Channel B at 20 watts into an eight ohm resistive load, driven by a 400 Hz sinewave.

OK, we’re back together again.  Here we have another gratuitous picture of the front of the rig.

The back of this unit is not nearly as pretty.  JC said, “Fix this mess!”

So we stripped everything out and went back with one channel of the audio chain.

This cable was intermittent and was replaced.  These ends are crimped onto the cable and are not serviceable.  Several layers of black duct tape attests to the fact that I am not the first person to come to the conclusion that this cable had a problem.  Hint: Why not try fixing the problem right when you find it, next time?

This is all the AC wiring that did NOT go back into this rig.

The AC cables were shortened and these rectangular plugs were fitted.  These plugs were chosen because they could fit on the AC outlet strip without blocking any outlets.  The black tie wrap augments the strain relief.

The AC power strip was disassembled so that a longer AC cord could be permanently affixed.

Here is the AC wiring and one channel of the audio cabling.  The other channel was similarly wired and dressed.

One Happy Customer!

Thanks for reading all the way to the bottom!

David Latchaw EE

281-636-8626

 

Please follow and like us: